Are you fed up with the VHDX disk expansion?

Here is a free solution from Systola I used to make VHDX disk expansion life easier. It’s a common requirement always to increase the disk size, when you want to create more Exchange Databases in a vhdx based disk or a temporary space requirement during your database defragmentation/mailbox move etc. Traditional method in a Hyper-V environment … Continue reading “Are you fed up with the VHDX disk expansion?”

The domain join cannot be completed because the SID..

I recently worked on fixing the following issue on my Windows 2012 R2 Data Center Edition servers in my Hyper-V lab: The domain join cannot be completed because the SID of the domain you attempted to join was identical to the SID of this machine Basically, I was trying to join a virtual machine to the … Continue reading “The domain join cannot be completed because the SID..”

Re-create OWA virtual Directories in Exchange 2013

Some times, you may be fed up with some sort of issues related to ‘owa’ , ‘ecp’ or any other virtual directories. Any repair or fine tuning mayn’t fix the issue and you will have to re-create the virtual directories from the scratch. The difference in Exchange 2013 is that, it has got 2 websites hosted … Continue reading “Re-create OWA virtual Directories in Exchange 2013”

Windows Server 2012 Naming Information cannot be located because: The specified domain either doesn’t exist or could not be contacted. (Applicable to Windows 2016 also)

This solution works for Windows 2016 also 🙂 I met a difficult situation while setting up a DC for a new forest in Windows Server 2012 . ADDS has been setup and promoted the server as the Domain Controller for the new forest/domain. But none of the AD tools were not able to open, says a … Continue reading “Windows Server 2012 Naming Information cannot be located because: The specified domain either doesn’t exist or could not be contacted. (Applicable to Windows 2016 also)”

Windows Server 2012 GUI went missing after removing features

Today morning I have come across an issue with one of the Windows 2012 machine of my client. The GUI went missing after removing ASP.NET 4.5 and a restart after that. The only thing I can see was the command prompt and the mouse cursor. I have researched on various ways to recover the situation … Continue reading “Windows Server 2012 GUI went missing after removing features”